FitMetrix members list page
Incident Report for FitMetrix
Resolved
The previous issue with access to the member's list page is now resolved. Thank you for your patience while we worked to resolve the issue.
Posted Jul 13, 2020 - 11:44 PDT
Investigating
Some FitMetrix customers may experience intermittent timeouts when accessing the member list page. We are working to diagnose the problem and restore functionality as soon as possible.
Posted Jul 13, 2020 - 10:23 PDT
This incident affected: FitMetrix Web.