FitMetrix LogIn Portal - Redirecting
Incident Report for FitMetrix
Resolved
We have identified and resolved the issue with fitmetrix.io and full functionality has been restored.
Posted 6 months ago. Apr 11, 2019 - 23:46 PDT
Identified
FitMetrix.io is currently experiencing issues with the login portal. Customers will not be able to log in at this moment. We are aware of the cause and are currently working on a resolution.
Posted 6 months ago. Apr 11, 2019 - 23:34 PDT
This incident affected: FitMetrix Web.